DSA_E1420 Online dump failed
search cancel

DSA_E1420 Online dump failed

book

Article ID: 372694

calendar_today

Updated On:

Products

CA Directory

Issue/Introduction

Error message "DSA_E1420 Online dump failed" appeared in the DSA alarm log.

Three methods can be used to do an online backup without having to shutdown a DSA according to the product doc:

Backing Up Data

and

dump dxgrid-db Command

 

They are:

1. running the following from command line
    dxserver onlinebackup dsaname

2. issue the following from the DSA console
    dump dxgrid-db;

3. use the following example in the settings configuration file of the DSA to do a online backup every hour:
   dump dxgrid-db period 0 3600;

When the dsa user has difficulty to write to the backup location, the online backup fails.

Environment

Release 14.1

Component: CA Directory

Cause

The user dsa either has no access to the backup location or the backup location does not exist.

Resolution

Two possible methods to resolve this issue:

1. Identify the designated database backup location, fix the access issue, and re-issue the online backup command.

2. Change the database backup path, re-start the DSA, and re-issue the online backup command.

The online backup location is by default using the same path as of the database files and can be set to an alternative location through

set dxgrid-backup-location = "<backup_file_location>";

as documented in:

Configuring the location of DXgrid datastore backup files