Service Alarms not closing automatically
search cancel

Service Alarms not closing automatically

book

Article ID: 372515

calendar_today

Updated On:

Products

DX Operational Intelligence

Issue/Introduction

Some Service Alarms only close after we click on them:

After clicking on it:

Why is this happening?

 

Environment

Dx OI SaaS
Dx OI any on-premise release.

Cause

This happens because the stalled alarm still has a ServiceAlarm associated with that, by default, it should be deleted in 30 days If there is no more activity on that.

By default, the retention period set to close stalled alarm is 30 days if no more activity on that. You can check what is set in your environment by doing:

  1. Enter into doi-readserver-podname
  2. Go to the path "cd caemm/resources/dbscripts/jarvis_itoa/"
  3. Command "cat patchRetentionPeriod.sh | grep service"

                curl -X PATCH "http://URL:PORT/onboarding/doc_type" -H "accept: /" -H "Content-Type: application/json" -d "{ \"doc_type_id\": \"itoa_service_cis_sa\", \"doc_type_version\": \"1\", \"product_id\": \"ao\", \"retention_period\": \"30\"}"
                curl -X PATCH "http://URL:PORT/onboarding/doc_type" -H "accept: /" -H "Content-Type: application/json" -d "{ \"doc_type_id\": \"itoa_services_sa\", \"doc_type_version\": \"1\", \"product_id\": \"ao\", \"retention_period\": \"30\"}

Resolution

You can change the stalled retention period by doing:

  1. Go to the Service Alarm pod "oc edit deploy doi-servicealarm -n dxi-prd
  2. Edit the doi-servicealarm by adding the following properties int the "Environment" section:

SA_STALE_SERVICE_ALARM_SYNCH_ENABLE=true
SA_STALE_SERVICE_ALARM_SYNCH_FROM_TIME=now-720

      3. Restart the POD.