VM General Settings Save button is greyed out for certain VMs in Cloud Director
search cancel

VM General Settings Save button is greyed out for certain VMs in Cloud Director

book

Article ID: 372456

calendar_today

Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • Virtual Machines(VM) settings on the General tab dialog box cannot be saved.
  • Updating the General Settings via VMware Cloud Director(VCD) API works as expected
  • No validation errors can be seen from the UI or browser logs.
  • Editing any existing value or ensuring all fields are correctly populated still doesn't 
  • Newly created from VMs in VCD does not show this issue.

Environment

VMware Cloud Director 10.5.x

Cause

The behavior is seen with VMs imported from vCenter and caused due to a UI validation issue.

The field Failed Boot Recovery Delay set on the VM is failing on VCD side due to a decimal value. This value is picked up from the VC side causing issues on the VCD side.

As the backend does not have this validation, VCD API allows the change to be applied.

Resolution

  • To resolve the issue, change the Failed Boot Recovery value for each affected VM in vCenter to a non-decimal value.

    The following is an example of an invalid configuration for Failed Boot Recovery Delay that was blocking the Save but was hidden when Failed Boot Recovery is disabled:



In this example, the Failed Boot Recovery Delay must be a whole number value and altering this to 0 corrects the behavior.

  • Engineering fixed the validation for this issue which is now available with VMware Cloud Director 10.6.1 release. You can download VMware Cloud Director 10.6.1 from the Broadcom Support Portal.