SDDC precheck failing with the error: A problem has occurred on the server. Please retry or contact the service provider and provide the reference token.
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Article ID: 372452
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Updated On:
Products
VMware Cloud Foundation 5.x
Issue/Introduction
The SDDC manager precheck gets stuck at 46% for long or fails with the below error:
A problem has occurred on the server. Please retry or contact the service provider and provide the reference token
Environment
VCF 5.0.x
VCF 5.1.x
Cause
This is a known issue where the vCenter session had expired before the discovery phase of the precheck workflow completed.
Resolution
The issue should be resolved in VCF 5.2.
Follow the below workaround to increase the VAPI session idle timeout:
Take a snapshot of the VC server.(Do not skip this step)
SSH to the vcenter using root user and enter shell mode if required
shell
Edit the vapi endpoint configuration
vim /etc/vmware-vapi/endpoint.properties
Find session.maxSessionIdleMilliseconds and increase its value - the default value is 1h, i.e. 3600000, you can try to increase it to 2h or even 3h, i.e. 7200000 or 10800000. Make sure to remove the # at the beginning so it takes effect
session.maxSessionIdleMilliseconds=7200000
Restart the vapi-endpoint service - to restart it we just stop it and start it again