SDDC precheck failing with the error: A problem has occurred on the server. Please retry or contact the service provider and provide the reference token.
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SDDC precheck failing with the error: A problem has occurred on the server. Please retry or contact the service provider and provide the reference token.

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Article ID: 372452

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Updated On:

Products

VMware Cloud Foundation 5.x

Issue/Introduction

The SDDC manager precheck gets stuck at 46% for long or fails with the below error:

A problem has occurred on the server. Please retry or contact the service provider and provide the reference token

Environment

VCF 5.0.x

VCF 5.1.x

Cause

This is a known issue where the vCenter session had expired before the discovery phase of the precheck workflow completed.

Resolution

The issue should be resolved in VCF 5.2.
 
Follow the below workaround to increase the VAPI session idle timeout:
 
  1. Take a snapshot of the VC server.(Do not skip this step)
  2. SSH to the vcenter using root user and enter shell mode if required
    shell
  3. Edit the vapi endpoint configuration
    vim /etc/vmware-vapi/endpoint.properties
  4. Find session.maxSessionIdleMilliseconds and increase its value - the default value is 1h, i.e. 3600000, you can try to increase it to 2h or even 3h, i.e. 7200000 or 10800000. Make sure to remove the # at the beginning so it takes effect
    session.maxSessionIdleMilliseconds=7200000
  5. Restart the vapi-endpoint service - to restart it we just stop it and start it again
    service-control --stop vmware-vapi-endpoint && service-control --start vmware-vapi-endpoint

     

  6. Ensure the service has started successfully by navigating to:
    https://vc_hostname_or_IP/vapiendpoint/health
  7. After the value is increased, run precheck again.

Additional Information

Please ensure there are no errors/warnings on the workload, if so please resolve those before running the precheck.