SDDC precheck failing with the error: A problem has occurred on the server. Please retry or contact the service provider and provide the reference token.
search cancel

SDDC precheck failing with the error: A problem has occurred on the server. Please retry or contact the service provider and provide the reference token.

book

Article ID: 372452

calendar_today

Updated On:

Products

VMware Cloud Foundation 5.x

Issue/Introduction

The SDDC manager precheck gets stuck at 46% for long or fails with the below error:

A problem has occurred on the server. Please retry or contact the service provider and provide the reference token

Environment

VCF 5.0.x

VCF 5.1.x

Cause

This is a known issue where the vCenter session had expired before the discovery phase of the precheck workflow completed.

Resolution

The issue should be resolved in VCF 5.2.
 
Follow the below workaround to increase the VAPI session idle timeout:
  1. Take a snapshot of the VC server.(Do not skip this step). Please refer to  "Snapshot Best practices for vCenter Server Virtual Machines" and "VMware vCenter in Enhanced Linked Mode pre-changes snapshot (online or offline) best practice" for more information.

  2. SSH to the vCenters using root user and enter shell mode if required

    shell

     3. Edit the vapi endpoint configuration

         vim /etc/vmware-vapi/endpoint.properties

    4. Find session.maxSessionIdleMilliseconds and increase its value. The default value is 1h, i.e. 3600000 ms. Increase it to 2h  i.e. 7200000 ms. (Make sure to remove the  # at  the beginning so it takes effect.)

        session.maxSessionIdleMilliseconds=7200000

     5. Restart the vapi-endpoint service by running following command. 

         service-control --stop vmware-vapi-endpoint && service-control --start vmware-vapi-endpoint

     6. Ensure the service has started successfully by navigating to:

         https://vc_hostname_or_IP/vapiendpoint/health

After the value is increased, run precheck again.

Additional Information

Please ensure there are no errors/warnings on the workload, if so please resolve those before running the precheck. 

Validate the licenses are correctly assigned and you do not see an alert for it. 

If an alert is showing Click on Assign License and ensure correct licenses are present on the SDDC manager.