Query the Status of vCenter Reduced Downtime Upgrade Operation
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Query the Status of vCenter Reduced Downtime Upgrade Operation

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Article ID: 372402

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Updated On:

Products

VMware SDDC Manager

Issue/Introduction

An error "A vCenter upgrade is already running" can be seen during vCenter reduced downtime upgrade is in progress and the vcenter reduced downtime upgrade operation will be failed.

Environment

VCF 5.2.1

Cause

There can be a previous vCenter Reduced Downtime Upgrade operation in progress because of which a precheck error is thrown, in such cases please query the status of the inprogress operation with the help of steps provided in this KB

Resolution

  1. Check the status of the upgrade by calling the vCenter Upgrade status endpoint directly on the vCenter that is being upgraded using root credentials. Do not use any other credentials to achieve optimal results: 

    • curl -u root:<Replace_with_Root_Password> --location 'https://{Replace_with_vCenter_Hostname}/lcm/rest/vcenter/lcm/deployment/migration-upgrade/status'

    The result of the operation will consist of many fields but the important ones are listed in the example below:


    {
        "desired_state": "UPGRADED",
        "status": "RUNNING",
        "error": {  # It is only shown if there are errors.
           "error_type": "ERROR",
           "messages": [...]
        } 
    }

  2. Inspect the returned JSON result and based on the values below make follow-up decisions:
    1. If result['status'] is "SUCCEEDED" or "CANCELED" -> the upgrade has reached the final state and there are no other actions that need to be taken using the status API.
    2. If result['desired_state'] is "UPGRADED" and result['status'] is "RUNNING" -> Upgrade is in progress, wait for the operation to complete or be canceled.
    3. If result['desired_state'] is "UPGRADED" and result['status'] is "FAILED" -> Upgrade has failed, automatic cancellation will start shortly if the status does not change in 1 minute, move to manual cancellation using KB https://knowledge.broadcom.com/external/article/311902.
    4. If result['desired_state'] is "CANCELED" and result['status'] is "RUNNING" -> Cancellation is in progress, wait for it to be completed by re-running the Status API call in some time.
    5. If result['desired_state'] is "CANCELED" and result['status'] is "FAILED" -> Cancellation has failed, use KB https://knowledge.broadcom.com/external/article/311902 to cancel manually after fixing the problem listed in result['error']