Alarm "Errors occurred on the disk(s) of a vSAN host" showing in vSAN Witness Host.
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Article ID: 372392
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Updated On:
Products
VMware vSphere ESXi
Issue/Introduction
Symptoms:
You see in vCenter the error "Errors occurred on the disk(s) of a vSAN host" on the summary tab of a vSAN Witness Host.
The disks are seen as healthy in the vSAN Disk Management.
You may also see errors with the vSAN Witness Appliance in vCenter as below:
vSAN data alarm ‘vSAN object’
vSAN physical disk alarm ‘Operation’
You perform backups for the vSAN Witness Appliance.
Environment
vSAN 7.0.x
vSAN 8.0.x
Cause
Backups, restores, clones and snapshots of a vSAN Witness Host are not supported.
Resolution
Clear the errors you are seeing using the steps below and do not back up the vSAN Witness Appliance.
To clear the error:
Restart the Witness Appliance.
Reset the alarm "Errors occurred on the disk(s) of a vSAN host" in vCenter to green.
If a restart of the witness doesn't help, please follow:
Take notes of the Fault Domains in use.
Un-stretch the vSAN Cluster.
Delete the Witness Disk Group.
Reset the alarm "Errors occurred on the disk(s) of a vSAN host" in vCenter to green.
Stretch the cluster again - while performing this task, you will create a new disk group for the witness.
Furthermore, in the future instead of having backups, clones or snapshots of a vSAN Witness Appliance, use the 'Change witness host' function in the vSphere Client to deploy a new Witness Host when there is an issue with the existing Witness Host.