HCX - Operations failing with "Error logging into VC endpoint"
search cancel

HCX - Operations failing with "Error logging into VC endpoint"

book

Article ID: 372347

calendar_today

Updated On:

Products

VMware HCX

Issue/Introduction

This error can be seen while performing any HCX operation when the username or password is incorrect. For example:

  • From the HCX Manager UI -> Migration, the following message/error will be displayed when you attempt to perform validation or during migration:

The following error is observed in /common/logs/admin/app.log

2024-07-17 02:30:03.496 UTC [LicensingService_SvcThread-6433, Ent: HybridityAdmin, , TxId: ########-####-####-####-############] ERROR c.v.v.h.a.vcenter.VcConnection- Error Logging onto VCenter:https://<vc.fqdn/ip> User: <username>, message: Cannot complete login due to an incorrect user name or password


OR

  • The same error can be seen in the HCX manager while creating a new Service Mesh

Environment

VMware HCX

Cause

The issue occurs due to an incorrect username or password used for communication between HCX Manager and vCenter.

Resolution

To fix the issue , update the vCenter credentials on HCX Admin page and restart web-engine and app-engine services.

  • Access HCX Manager Admin UI on port 9443 (https://hcx-ip-or-fqdn:9443).
  • Navigate to Configuration > vCenter Server > Edit and re-enter the correct vCenter username and password.
  • Navigate to Appliance Summary > HCX Services
  • Restart the Web Service and Application Service
  • Click STOP, and then START for both services.
  • Once that is done, edit the Site Pair and add the correct credentials.

Additional Information

For "Error communicating to VC endpoint" : Check HCX - Migration failed with the error: "Unexpected status code: 503"