NSX messaging-manager service shown as DOWN in NSX UI
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NSX messaging-manager service shown as DOWN in NSX UI

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Article ID: 372323

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Updated On:

Products

VMware NSX

Issue/Introduction

When you navigate to System>Appliances and click View Details for one of the NSX Manager nodes, you see messaging-manager service is down.

Check if the messaging-manager service is running via CLI:

  • Access the CLI to the affected NSX Manager as admin.
  • Check if the management services are running, with the command: get cluster status
  • The Messaging-Manager service group would show DEGRADED for the cluster, and DOWN for the affected NSX Manager.
  • Alternatively, you can also run the command: get service messaging-manager

Environment

VMware NSX 4.x
VMware NSX-T Data Center 3.x

Cause

This is most likely due to the messaging-manager service being down on the specific node.

 

Resolution

  • If the service is indeed DOWN and it is not a UI issue, start the service by running the command: start service messaging-manager
    Allow a few minutes and refresh the manager UI.
  • If the service is not DOWN and there are no related alarms, reboot the affected NSX Manager.
  • If the service remains in DOWN status even after rebooting the NSX manager, and the log file at /var/log/messaging-manager/messaging-manager.log contains lines such as this one:
io.netty.handler.codec.DecoderException: javax.net.ssl.SSLHandshakeException: error:14094412:SSL routines:ssl3_read_bytes:sslv3 alert bad certificate
  • then you need to run the automated remediation tool from our KB 369034 on the affected NSX Manager, and reboot this Manager once its truststore has been corrected with the correct certificate by the script