Title: Alarm for Down Status of Load Balancer Pool
Event ID: load_balancer.pool_status_down
Alarm Description:
Purpose: To inform users that the load balancer pool is down.
Impact: All the traffic to this pool is broken.
Environment
VMware NSX-T Datacenter VMware NSX
Cause
The network to all backend servers in this pool may be unreachable.
The service in all backend servers is not working well.
Resolution
Steps to resolve For 3.0.0 and higher
Recommendation Action:
Consult the load balancer pool to determine which members are down by invoking the NSX CLI command `get load-balancer <lb-uuid> pool <pool-uuid> status` or NSX API GET /policy/api/v1/infra/lb-services/<lb-service-id>/lb-pools/<lb-pool-id>/detailed-status.
If DOWN or UNKNOWN is reported, verify the pool member. Check network connectivity from the load balancer to the impacted pool members.
Validate application health of each pool member. Also validate the health of each pool member using the configured monitor.
When the health of the member is established, the pool member status is updated to healthy based on the 'Rise Count' configuration in the monitor.
Remediate the issue by rebooting the pool member or make the Edge node enter maintenance mode, then exit maintenance mode.
Maintenance window required for remediation? Optional.