"Load balancing configuration not realized due to lack of memory" Alarm when pushing configuration to NSX Load balancer
search cancel

"Load balancing configuration not realized due to lack of memory" Alarm when pushing configuration to NSX Load balancer

book

Article ID: 372277

calendar_today

Updated On:

Products

VMware NSX

Issue/Introduction

  • When pushing configuration to NSX Load balancer, the configuration fails with error: "load_balancer.load_balancing_configuration_not_realized_due_to_lack_of_memory".
  • The alarm is raised despite there is free memory available on the Edge node.
  • The alarm is raised to inform users that the load balancer lacks sufficient memory resources to apply the new configuration.
  • In the Edge logs, under /var/log/syslog, there will be a repeating log message indicating that the required memory for the new config is higher than the available memory:
    2025-04-02T07:41:52.934Z <NSX_LoadBalancer_Name.Domain> NSX 22991 LOAD-BALANCER [nsx@6876 comp="nsx-edge" subcomp="lb" s2comp="lb" level="INFO"] [########-####-####-####-########] cfg: not enough mem available for new config processing, min needed 11693520 KB, current free 11249264 KB

Note: The timestamps, appliance names, process IDs, and memory figures are just an example.

Environment

  • VMware NSX-T Datacenter 3.2.0 and higher.
  • VMware NSX 3.2.0 and higher.

Cause

  • The issue may caused by insufficient memory on the edge node due to design consideration.

Resolution

The behavior aligns with the current NSX design and limitations, but there are a few ways to alleviate the issue, such as:

  1. Create more small and medium-sized load balancers instead of a few large-sized load balancers.
  2. Spread out load balancer services among the available Edge nodes.         
  3. Reduce the number of Virtual Servers defined on the impacted Edge nodes.

Is a maintenance window required for remediation? Yes

Additional Information

If the sizing & capacity planning of the load balancer complies with the Configuration Maximums, the issue might be related to how the worker processes operate during configuration updates. For more information, please look into the below KB article.

Edge Memory Usage High alarm when nginx worker processes waiting to be shut down