Logical Switches stuck as "In Progress" state
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Logical Switches stuck as "In Progress" state

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Article ID: 372106

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Updated On:

Products

VMware NSX

Issue/Introduction

In the NSX GUI at Networking → Segments, several segments appear as "In Progress" in the "Status" column.

These segments have been "In Progress" for more than a few hours or days.

Environment

NSX-T 4.1.x

Cause

Logical Switch Port groups that were originally deployed in vCenter before migrating into NSX. Afterwards, those port groups  were removed via vCenter without removing them from NSX. This leaves stale entries in NSX for these segments.

Resolution

Open an SR with NSX team. Provide them with the following information:

  1. Screenshots of the Logical Switches stuck "In Progress".
  2. Log into an NSX Manager as root (or st en from admin) and run the following two commands, saving the output to a file, and scp those files off of the manager to add to your case:
    /opt/vmware/bin/corfu_tool_runner.py -o showTable -n nsx -t LogicalSwitchState > LogicalSwitchStateDump.txt
    /opt/vmware/bin/corfu_tool_runner.py -o showTable -n nsx -t ComputeManagerStatusModelMsg > ComputeManagerStatusModelMsg.txt
  3. Run the following api-call against your nsx-manager using either curl or postman, save the output to a file and add it your case:
    GET https://{{nsx-ip}}/api/v1/transport-nodes

Additional Information

Logical Switches are also known as Segments. Policy Mode and Manager Mode alternate between these terms.