When attempting to access Xtraction the following error occurs: General Error a error has occurred. Check the application log for details.

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Article ID: 37208

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Updated On:

Products

SUPPORT AUTOMATION- SERVER CA Service Desk Manager - Unified Self Service KNOWLEDGE TOOLS CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

Description:

When attempting to access Xtraction the following error occurs:
General Error A error has occurred. Check the application log for details.

Log file error:

Querystring : ReturnUrl=%2fXtraction%2f
IP : 10.0.0.63
User Id :
Machine User Id : IIS APPPOOL\Xtraction
System.Data.SqlClient.SqlException (0x80131904): The SELECT permission was denied on the object 'Folder', database 'Xtraction', schema 'dbo'

Cause:

Permissions set to the Xtraction database are incorrect or missing. Without the proper roles the connection to the database will fail.

Resolution:

1. Open SQL server Management studio
2. log in with the SA account
3. Open Logins folder.
4. Right click on user xtraction.
5. Select Properties.
6. Select User Mapping.
7. Ensure that for the Xtraction database the "Xtraction" user has selected in the database role membership the following roles: db_datareader,db_datawritter and public.
8. Ensure that for the MDB database the "Xtracion" user have the role db_datareader and public selected.

 

Environment

Release: SDMU0M99000-14.1-Service Desk Manager-Full License
Component: