Error Code: LCMVRAVACONFIG90030, vracli error: "No patch for the current product found in the repository" when upgrading or applying Aria Automation patch
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Error Code: LCMVRAVACONFIG90030, vracli error: "No patch for the current product found in the repository" when upgrading or applying Aria Automation patch

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Article ID: 372059

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

If both of the following conditions are met, then there is a previous upgrade which has not been finalized on the Automation appliance:

  • Error Code: LCMVRAVACONFIG90030 when upgrading or applying Aria Automation patch

  • Running command 'vracli upgrade status --details' on the Aria Automation VA returns the below example error:

"No patch for the current product found in the repository. Expected 8.14.1 , found: 8.16.2"

 

For another possible cause of error LCMVRAVACONFIG90030, see KB article #424939.

Environment

Aria Automation 8.16.x

Aria Automation 8.17.x

Aria Automation 8.18.x

Cause

Old upgrade files cause an issue blocking new upgrade or patching.

Resolution

  1. Connect to the Aria Automation node via SSH as the root user.
    • If the environment is a 3 node cluster only run the following from a single node as the command is cluster aware.  
  2. Execute the following command on the appliance:
    • vracli cluster exec -- bash -c 'rm -rf /data/restorepoint /var/vmware/prelude/upgrade /var/log/vmware/prelude/upgrade-report-latest*; crontab -u root -l | grep -v -F "/opt/scripts/upgrade/upg-mon.sh" | crontab -u root -'
  3. Return to the Aria Suite Lifecycle Manager UI
  4. Navigate to the failed request and select "Retry"