Filter [FacesFilter]: could not be initialized
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Filter [FacesFilter]: could not be initialized

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Article ID: 372052

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Updated On:

Products

CA Identity Portal

Issue/Introduction

When a user tries to log in to the Identity Manager User Console, the following error is displayed in the browser.


Filter [FacesFilter]: could not be initialized

 

With Identity Manager installed on WAS (WebSphere Application Server) and the environment configured via the management console, the user environment console is not accessible resulting on the error above on the browser screen.

The application server log shows the following errors regarding JSF.

[7/9/24 14:34:59:312 GMT] 0000006f webapp        I com.ibm.ws.webcontainer.webapp.WebGroupImpl WebGroup SRVE0169I: Loading Web Module: IMS-UI.

[7/9/24 14:34:59:321 GMT] 0000006f WASSessionCor I SessionContextRegistry getSessionContext SESN0176I: Will create a new session context for application key default_host/iam/im

[7/9/24 14:34:59:421 GMT] 0000006f MyFacesContai I   Added FacesServlet with mappings=[/faces/*, *.jsf, *.faces]

[7/9/24 14:34:59:422 GMT] 0000006f webapp        I com.ibm.ws.webcontainer.webapp.WebApp log SRVE0292I: Servlet Message - [iam_im#user_console.war]:.No Spring WebApplicationInitializer types detected on classpath

[7/9/24 14:34:59:436 GMT] 0000006f MyfacesConfig I   Starting up Tomahawk on the MyFaces-JSF-Implementation

[7/9/24 14:34:59:437 GMT] 0000006f DefaultFacesC I   Reading standard config META-INF/standard-faces-config.xml

[7/9/24 14:34:59:451 GMT] 0000006f Digester      E org.apache.commons.digester.Digester endElement End event threw exception

                                 java.lang.NoSuchMethodException: No such accessible method: addResourceHandler() on object: org.apache.myfaces.config.impl.digester.elements.Application

 

 

Environment

Identity Manager on WebSphere Application Server.

Cause

The wrong version of JSF, JavaServer Faces, is configured or detected by the WAS application server.

IDM supports only JSF 1.2.

 

Resolution

Verify that the correct JSF version is configured in WebSphere.

Log in to the WebSphere admin console and change the JSF Implementation from DEFAULT to SunRI1.2 under Enterprise Applications, castylesr5.1.1, JSP, JSF, and restart the server. 

If SunRI1.2 is already selected, temporarily change the selection to DEFAULT, then save it, then change it back to SunRI1.2, save, and restart the application server.

 

Additional Information

The JSF implementation is intended to be configured before the IDM installation is run as documented in Identity Manager WAS installation.

The resolution to the error is also documented as a known issue.

However, it is possible that the configuration is set correctly in the WAS console but is not being initialized properly by WebSphere. This can be resolved by toggling the JSF setting to DEFAULT and back to SUNRI1.2 as described in the resolution.