Bulk or RAV Migration failure with "Error Creating Group"
search cancel

Bulk or RAV Migration failure with "Error Creating Group"

book

Article ID: 372025

calendar_today

Updated On:

Products

VMware HCX

Issue/Introduction

  • The initial Bulk Migration or RAV (Replicated Assisted vMotion) was initiated with "Enable Seed Checkpoint", but the migration failed during the base sync replication phase.
  • The migration was re-initiated using the "existing seeds" option, which resulted in "Error Creating Group".
  • Migration of another VM's works, which rules out the HCX-IX issue.
  • The  /common/logs/admin/app.log of the target HCX Manager shows the following ERROR.
    <time stamp> [ReplicationTransferService_SvcThread-42023, Ent: HybridityAdmin, , TxId: TxId: #######-####-####-####-######] ERROR c.v.h.s.r.jobs.SetupTarget- Job (#######-####-####-####-#######) failed with exception java.lang.RuntimeException: Error Creating Group

Environment

VMware HCX

Cause

  • The previous migration during the base sync phase failed, (due any network outage or space issue etc..), affecting the integrity of the target delta disks to be reused as seeds.
  • The above error is due to incomplete or corrupted seed checkpoint delta disks on the target datastore that were left over from the initial failed migration.

Resolution

  • Perform a migration job clean-up and remove the seed checkpoint disks from the target datastore.

    • Log in to the HCX Manager UI https://hcx-fqdn-ip
    • Go to the Migration Tab
    • Click on the Migration job and Force Cleanup

    • This deletes the delta disks replicated during the initial migration attempt.
    • Re-initiate the migration again with "Enable Seed Checkpoint"

  • Note: When the job is reinitiated after the deletion of delta seed disks on the target, the base sync starts from the beginning.