crash of sd_jexe.exe process during execution of SD Jobs
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crash of sd_jexe.exe process during execution of SD Jobs

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Article ID: 371980

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Updated On:

Products

CA Client Automation - IT Client Manager CA Client Automation

Issue/Introduction

sd_jexec.exe is crashing with following details :

sd_jexec.exe caused an EXCEPTION_ACCESS_VIOLATION in module sd_jexec.exe at 0023:00D0DFB5, StopOrderAbort::StopOrderAbort()+2485 byte(s)

Call Stack:
0023:00D0DFB5 (0x0053E7D8 0x6EA89DA0 0x0196CFB8 0x6EA89E30) sd_jexec.exe, StopOrderAbort::StopOrderAbort()+2485 byte(s)
0023:00D058B0 (0x6EA89DA0 0x01963C48 0x6EA89E30 0x007107D0) sd_jexec.exe, Directory::operator=()+91728 byte(s)
0023:00CEE520 (0x0053F89C 0x0053F8D4 0x00DA4D04 0x008F3A83) sd_jexec.exe, FileSysIterator::operator=()+44816 byte(s)
0023:00D3429E (0x00CE0000 0x00000000 0x008F3A83 0x0000000A) sd_jexec.exe, StopOrderAbort::StopOrderAbort()+158878 byte(s)
0023:00D4CB5A (0x002AB000 0x76E7FA10 0x0053FA3C 0x77407A9E) sd_jexec.exe, InPossession::operator=()+22746 byte(s)

or

sd_jexec.exe caused an EXCEPTION_ACCESS_VIOLATION in module sd_jexec.exe at 0023:00BBB920, StopOrderAbort::`vftable'()+69004 byte(s)

Call Stack:
0023:00BBB920 (0x028C7638 0x00000002 0x00000001 0x00000006) sd_jexec.exe, StopOrderAbort::`vftable'()+69004 byte(s)
0023:00B44DBD (0x6A919DA0 0x0287B4A0 0x6A919E30 0x00B107D0) sd_jexec.exe, Directory::operator=()+88925 byte(s)
0023:00B2E520 (0x0099F7CC 0x0099F804 0x00BE4D04 0x0115CA4B) sd_jexec.exe, FileSysIterator::operator=()+44816 byte(s)
0023:00B7429E (0x00B20000 0x00000000 0x0115CA4B 0x0000000A) sd_jexec.exe, StopOrderAbort::StopOrderAbort()+158878 byte(s)
0023:00B8CB5A (0x00DA3000 0x7592FCB0 0x0099F96C 0x77837C6E) sd_jexec.exe, InPossession::operator=()+22746 byte(s)

Environment

Client Automation 14.5 CU6 or CU7

Cause

This problem occurs if

  • The Agents have in the configuration a "Job Check: Pre-command" containing a command taking some seconds to be executed.

    Example :

    DSM/Software Delivery/Agent/Job Check: Pre-command = timeout /T 15

AND

  • Nobody is logged on the computer and a SD Job is sent. SD Agent is started and execute the Pre-command.

    AND

  • User logon at the same time as end of execution of Pre-command.
    Crash occurs.

Resolution

Open a case at Broadcom technical Support and ask for the fix T55V439
 
This fix could be installed on SD Agent 14.5 CU6 or CU7
It provides the file sd_jexec.exe
 
Size = 809 216 bytes
Modified Date = 04/07/2024
Version = 14.5.7.633