Unable to configure IG-IM connector after upgrade was applied
search cancel

Unable to configure IG-IM connector after upgrade was applied

book

Article ID: 371922

calendar_today

Updated On:

Products

CA Identity Suite CA Identity Manager CA Identity Governance

Issue/Introduction

After applying Cumulative Patch to the system - the IG-IM connector is not working

Error in IM log may show.

ERROR [ims.ui] java.lang.NullPointerException
ERROR [io.undertow.request] (default task-1) UT005023: Exception handling request to /iam/im/ws/wsconfiguration/identityEnv: javax.servlet.ServletException: java.lang.IllegalArgumentException: Object type Administrative_Units_Container is not valid for extension Azure
        at org.glassfish.jersey.servlet.WebComponent.serviceImpl(WebComponent.java:432)
        at org.glassfish.jersey.servlet.WebComponent.service(WebComponent.java:370)

Environment

IM/IG system version 14.4 and up.

Cause

As part of upgrade we provide new metadata for connectors like Azure. If the metadata is not deployed it may cause issues like this.

Resolution

Way to fix:

  1. Connect to Connector Server using Connector Xpress
  2. Update the Azure connector metadata to the latest, restart IM and IG
  3. It should solve the problem.

Exact steps are provided here.

 

Additional Information

Alternative way is to remove Azure Endpoint Screens if Azure Endpoint is not in use.