How to reset the cabi password to the default password
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How to reset the cabi password to the default password

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Article ID: 371888

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Updated On:

Products

CA Unified Infrastructure Management On-Premise (Nimsoft / UIM) CA Unified Infrastructure Management SaaS (Nimsoft / UIM) DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

cabi probe turns red and this error is displayed in the cabi.log:

Caused by: java.io.IOException: Can't log into cabi! Tried rest user password, default superuser and set superuser.

Environment

  • DX UIM 20.4 or higher

Cause

cabi probe turns red with this error:

Caused by: java.io.IOException: Can't log into cabi! Tried rest user password, default superuser and set superuser.

or the CABI probe superuser password was not set to the default before the upgrade.

Resolution

Run through the following steps to resolve the issue:

1. Set the CABI password to the default by running this query on the database:

         UPDATE jiuser SET password = '' WHERE username = 'superuser';

2. Login to the CABI page using the username superuser (no password is needed)

3. Then go to Manage, then Users, and then select the superuser

4. Then edit, then type superuser as the password then click Save

5. Set the cabi_rest_user key in the CABI probe's raw configure to be superuser then click 'Apply'

6. Restart the CABI robot and verify the issue is resolved.


If the issue persists, or you cannot login due to "Invalid Credentials Supplied," please check the following KB Article:

UIM - CABI invalid credentials supplied: could not login to CA Business Intelligence


If the issue still persists, open a support case and attach the logs:

$UIM_HOME\Nimsoft\probes\service\cabi\cabi.log

$UIM_HOME\Nimsoft\probes\service\cabi\_cabi.log

$UIM_HOME\Nimsoft\probes\service\wasp\webapps\cabijs\WEB-INF\logs\jasperserver.log

wasp Log: $UIM_HOME\\Nimsoft\probes\service\wasp\wasp.log

Additional Information

Note that installing more than one CABI instance in the same UIM domain is not supported.  This is documented here:

CABI v23.4.x release notes

The same statement is published for prior versions of CABI used with UIM 20.4 here:

UIM 20.4 CABI Release notes

It states the following:

Bundled CABI supports fresh installation and upgrades. For more information about the upgrade path, see Upgrade path.
Bundled CABI installation is supported on a different robot and the Operator Console system. You can install only one instance of CABI in a DX UIM domain.
High Availability (HA) of Jasper Server is not supported with the bundled CABI. HA-enabled Jasper Server instances can be pointed by using cabi_external.