Post upgrading the ITSM plugin all Jobs stuck at Ready state on ServiceNow
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Post upgrading the ITSM plugin all Jobs stuck at Ready state on ServiceNow

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Article ID: 371746

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

Post upgrading the ITSM plugin with skipped version and without following the best practice of performing an incremental version upgrade.   

Environment

  • Verify that the version of Aria Automation and the ITSM plugin is compatible. 
  •  Validate that the MID server is in UP status . 
  • Check install/upgrade history -
    Type plugins in the filter navigator
    Search for "VMware vRealize Automation ITSM Application" plugin
    Click on the 3 dots against the ITSM plugin
    Click on "view upgrade history"
    Analyze the history to confirm if there were some errors or warnings in the process of installation/upgrade.
    Check if any error log(s) is captured in installation logs? - Check for the errors like related to Plugin errors in service now under system logs

Cause

There were skipped error under Upgrade history. 

The records will fall into Skipped and Skipped Manual Merge if the user forgets to update the Replace on upgrade flag.

Resolution

  • Navigate to plug-in and click View upgrade history. The Upgrade Details page will open.
  • Under the Skipped Changes to Review tab, find all the Skipped Manual Merge, and Skipped records that are listed. 
  • Open each one of the records and click the Resolve Conflicts button to verify if there are any conflicts in the Customized record compared to the Base System record.
  • Go back to the Upgrade Details page and click the Revert to Base System button.

Additional Information

Note:

If you have any customized record for the plug-in, you must copy your customizations and mark that record to Revert to base System and update again as per your customization.