DX NetOps CA Mediation Manager (CAMM) Device Pack Cannot Retrieve Data
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DX NetOps CA Mediation Manager (CAMM) Device Pack Cannot Retrieve Data

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Article ID: 371711

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Updated On:

Products

DX NetOps CA Mediation Manager

Issue/Introduction

 After installing a device pack, status seems to be online and working:

However, the system is not able to retrieve inventory and data from the device.

 

 

Environment

DX NetOps CAMM all currently supported releases

Cause

The credentials configured for HTTP-Soap requests in the ENGINE might be incorrect or expired.

Resolution

To confirm, run the following command 

curl -k -u username:password --location 'https://<DEVICE_IP>:8443/xmlapi/invoke' --data '<SOAP:Envelope xmlns:SOAP="http://schemas.xmlsoap.org/soap/envelope/"><SOAP:Header><header xmlns="xmlapi_1.0"><security><user>username</user><password hashed="false">password</password></security><requestID>SamOClient:123</requestID></header></SOAP:Header><SOAP:Body><ping xmlns="xmlapi_1.0"/><timeStamp xmlns="xmlapi_1.0"/><version xmlns="xmlapi_1.0"/></SOAP:Body></SOAP:Envelope>'

Just change the username and password and the IP Address - <DEVICE_IP> in the CURL command before executing. 

The expected response is 200 ok.

In the case that the credentials are invalid, then it might result in a http error code OR "it will redirect to some other login server".