Connecting an ESXi host in vCenter fails with error: A general system error occurred: Host management agents not reachable on host
search cancel

Connecting an ESXi host in vCenter fails with error: A general system error occurred: Host management agents not reachable on host

book

Article ID: 371582

calendar_today

Updated On:

Products

VMware vCenter Server VMware vSphere ESXi VMware vSphere ESXi 7.0 VMware vSphere ESXi 8.0 VMware vCenter Server 7.0 VMware vCenter Server 8.0

Issue/Introduction

  • Unable to connect a disconnected Host back to the vCenter.

  • Unable to connect a new standalone Host to vCenter: 

  • Errors out with below error message in the vpxd.log of the vCenter.

Environment

VMware vSphere ESXi 7.x

VMware vSphere ESXi 8.x

VMware vCenter 7.x

VMware vCenter 8.x

Cause

This issue can occur if the host certificate has one of these problems:

  • The host name does not match the Subject Name(s) in certificate.
  • vCenter Server is unable to recognize the local issuer certificate.

Resolution

To resolve this issue, follow the below steps

  1. Take Snapshot of the vCenter. (Offline Snapshot if vCenter are in ELM).
  2. Click on the vCenter object on top left in the Inventory.
  3. Click on the Configure Tab -> Advanced Settings.
  4. Set the vpxd.certmgmt.mode to thumbprint or vmca from custom.
  5. SSH to vCenter
  6. Restart the vpxd Service.
    service-control --restart vpxd
  7. Reconnected the Host (provide the Host' root credentials if prompted).

Additional Information

Note:

  1. This setting won't affect the other connected Hosts in the vCenter.
  2. If the issue still persists, then remove the Host completely from the vCenter Inventory and re-add.
  3. If the Host(s) are in DVS, please do involve the Networking Team before performing Step 2.