Unable to login to Aria Operations. Error: "User not privileged for interactive login"
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Unable to login to Aria Operations. Error: "User not privileged for interactive login"

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Article ID: 371508

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

While trying to login to Aria Operations 8.x with vIDM, users encounter an error message "User not privileged for interactive login." This prevents users from logging in to the Product UI.

From the analytics.audit.log we see repeated successful authentication request, but the user is not authenticated:

server.device/logs/analytics.audit-XXXX.log:2024-08-29T21:17:25,684+0000 - UserId : XXXXX-XXX-XXXX-XXXX, UserName :XXXXXX, AuthSource : VIDM, Session : XXXXXX-XXXXX-XXXX-XXXXX-XXXXXX, ClientIP : n/a, Category : AUTHENTICATION_LOGIN - Log in succeeded. Origin: "UI".



Environment

Aria Operations 8.x and above.

Cause

The user's account role lacks the permission required for interactive login.

 

Resolution

Grant Interactive Login Permission

  • Login to the Aria Operations Product UI using a user account with administrative privileges..
  • From the left menu, access Administration panel.
  • Click on Access Control.
  • Go to the Roles tab.
  • Identify and edit the specific role assigned to the affected user(s).
  • Under Assign Permissions, go to Administration section.
  • Expand Access Control and check the box for Login interactively.
  • Click Save to apply the changes.

Additional Information

 

  • You need to have administrative access to modify user roles and permissions.
  • Granting "Login interactively" permission allows users to log in directly to the system interface.
  • Make sure the user is assigned to the proper role that has the setting "login interactively" enabled, in some instances importing a role from another instance that does not have the setting, will cause users to not be able to authenticate