Unable to delete content pack via UI
search cancel

Unable to delete content pack via UI

book

Article ID: 371496

calendar_today

Updated On:

Products

VMware Aria Suite

Issue/Introduction

Uninstalling Content Pack failed. Request failed 440 (client error 440) error while trying to uninstall content pack from UI.

Error found in ui_runtime.log:

[2024-04-09 11:15:13.525+0000] ["https-openssl-apr-443-exec-7"/xx.xx.xx.xx ERROR] [com.vmware.loginsight.web.actions.misc.ContentPackActionBean] [Uninstalling content pack failed, com.vmware.vro]
com.vmware.loginsight.api.ApiException: Request failed. 440: Client Error (440)
 at com.vmware.loginsight.api.ApiClient.handleNotSuccessfulResponse(ApiClient.java:616) ~[webservice-lib.jar:?]
 at com.vmware.loginsight.api.ApiClient.request(ApiClient.java:469) ~[webservice-lib.jar:?]
 at com.vmware.loginsight.api.ApiClient.request(ApiClient.java:358) ~[webservice-lib.jar:?]
 at com.vmware.loginsight.api.ApiClient.authenticatedRequest(ApiClient.java:349) ~[webservice-lib.jar:?]
 at com.vmware.loginsight.api.ApiClient.request(ApiClient.java:275) ~[webservice-lib.jar:?]
 at com.vmware.loginsight.api.ApiClient.jsonRequest(ApiClient.java:267) ~[webservice-lib.jar:?]
 at com.vmware.loginsight.web.actions.misc.ContentPackActionBean.deleteContentPack(ContentPackActionBean.java:380) [classes/:?]

<daemon host="xx.xx.xx.xx " port="16520" token="45ce8cae-8889-4e04-9dc6-07bd56401fda">
      <service-group name="workernode" />
    </daemon>
[2024-04-29 16:47:23.096+0000] ["https-openssl-apr-443-exec-17"/xx.xx.xx.xx ERROR] [com.vmware.loginsight.web.actions.misc.ContentPackActionBean] [Uninstalling content pack failed, com.vmware.vra.75]
com.vmware.loginsight.api.ApiException: Request failed. 440: Client Error (440)

Environment

Aria Operations for Logs 8.16.x

Cause

1. When trying to uninstall a content pack an API client is created (with 60 seconds TTL session) to call the corresponding API. Before calling the Delete content pack API some preparation work is done (related to Content pack extracted fields).

2 The amount of time above preparation work takes is proportional to the number of users in Aria Operations for Logs. If this API call takes more than 60 seconds to complete, the session gets expired causing failure in uninstalling content pack.

The session is not extended before executing the API call, hence we see this indication in the logs that the API was called with expired session and it is failing.

Resolution

This is a known issue and is expected to be fixed in upcoming release of Aria Operations for Logs.
 
 
Workaround:
 
You can uninstall the Content Pack using API method.
 
1. Navigate to http://<Primary_Node_IP>/rest-api
 
2. POST https://[Primary_Node_IP]:9543/api/v2/sessions
with request body:
{
    "username":"admin",
    "password": "[admin_password]",
    "provider":"Local"
}
Replace [Logs IP] and [admin_password] with correct values beforehand.
 
3. Copy the session ID value from the response.
 
4. DELETE https://[Primary_Node_IP]:9543/api/v2/content/contentpack/[content pack namespace]
Add Authorization header with following value "Bearer [session ID from previous call]"
 
Observe the status code: If it is 200 OK, then the content pack shall be removed from the system and not appear in the UI as well.