Rally: Capacity Planning page won't load or loads with errors
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Rally: Capacity Planning page won't load or loads with errors

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Article ID: 371418

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Updated On:

Products

Rally SaaS

Issue/Introduction

Unable to access Backlog page.  Error, "Whoops! We hit a snag.  Top people are working on it."

Or the page loads with errors.

Cause

When the Capacity Planning page won't load, it is usually due to a corrupt filter setting which prevents the page from loading.  Filters are saved as a Preference on a per-user basis.  To clear the potentially corrupt filter setting, you can delete the filter preference.  Each user experiencing this issue will need to walk through the process to clear their own preference. 

Resolution

The preference deleter is available as a community app from GitHub.  In order to install it, perform the following steps:

  1. On your dashboard or a custom page, add the "Custom HTML" app from the App Catalog.
  2. Paste the Preference Deleter code from This URL into the HTML section of the custom HTML application and <Save>.
  3. You will be prompted to enter the Preference Name: data-table-default/-222445
  4. Make sure there are no beginning or ending spaces in the entry and click Find Preference.
  5. Then click the Delete button and confirm
  6. Delete Preference Permanently.
  7. Once you have deleted all preferences, click the Find Preference button again and ensure that you see a popup box titled Preference Not Found.
  8. Logout immediately (don't navigate to any other page, so as not to save any additional preferences).
  9. Log back in and check the page that had the issue.

See this video for a walkthrough on adding a custom app

Additional Information

Keywords:  

Error:  Could not parse: Could not find attribute "TypeDefOid" on type WorkingCapacityPlan in query segment "TypeDefOid"