Scheduled reports aren't exported automatically to ODBC database table
search cancel

Scheduled reports aren't exported automatically to ODBC database table

book

Article ID: 371392

calendar_today

Updated On:

Products

CA Client Automation - IT Client Manager CA Client Automation

Issue/Introduction

In DSM Reporter is possible to configure Scheduled reports, and when this is done, it's also possible to set that the result is automatically exported to ODBC database table, as explained here:

Specify Properties for a Scheduled Report

When this is set, the scheduled report isn't being exported automatically, but when done manually, it works.

Environment

Client Automation 14.5 and above.

Cause

When configuring a scheduled report to export the result into a ODBC database table, the following error is seen in TRC_REPORTER log:

|INFO   | CDb_Ado::ExecSQL() enter - DROP TABLE RPTMP_FE0E06_01
|NOTIFY | evalSQLInfo sqlstate: 42S02 native error: 3701 0xe75
|NOTIFY | evalSQLInfo class: 11 state: 5 server: database_server
|NOTIFY | Error Message: ADO Version 10.0 - COM Error: ErrorCode:-2147217865,WordErrorCode:3127, IDispatch error #3127, Cannot drop the table 'RPTMP_FE0E06_01', because it does not exist or you do not have permission., Microsoft SQL Server Native Client 11.0, (null)

|INFO   | UnUsed Pool Size is 2 less than the Max pool Size 3
|WARNING| ODBC: [Diag] 28000: [Microsoft][ODBC SQL Server Driver][SQL Server]Login failed for user 'database_user'.
|WARNING| ODBC: User database_user unable to connect to DSN custom_odbc

Even though the the test for "custom_odbc" works as expected:

Resolution

Open a support case and request fix T437417.