PIM: 汎用 SPECIALPGM や PACL が再起動後動作しない
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PIM: 汎用 SPECIALPGM や PACL が再起動後動作しない

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Article ID: 371356

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CA Privileged Identity Management Endpoint (PIM) CA Privileged Access Manager - Server Control (PAMSC)

Issue/Introduction

Privileged Identity Manager (以下、 PIM) で 汎用の SPECIALPGM または、PACL を登録したが、PIM の再起動後、正常に動作しない。
監査ログには、アクセスしたプログラムのフルパスではなく、プログラム名のみが記録されていた。

例:

SPECIALPGMを以下のように定義する。

AC> er SPECIALPGM /full/path/* pgmtype(FULLBYPASS)

この定義では /full/path/ 以下のプログラムはすべてのアクセスの処理をバイパスされることが期待される。
ところが、PIMの再起動後、/full/path/program でのアクセスがバイパスされず、監査ログは以下のように記録される。

DD MON YYYY HH:MM:SS P FILE <user> Read 54 2 <保護されるファイル> program <user>

Environment

Privileged Identity Manager: Linux/UNIX 版の全てのバージョン

Privileged Access Manager Server Control: Linux/UNIX 版の全てのバージョン

Cause

この事象は PIM が再起動した際に、プログラムのフルパスの情報が OS から得られないことに起因します。

PIM は再起動する際に OS の情報として /proc 配下から実行プログラムの情報を取得し製品内部のプロセステーブルに情報を格納します。
この時のプロセス情報にフルパスの情報が含まれていない場合、 PIM ではフルパスの情報を取得することができません。
ここで、プログラム名だけだと SPECIALPGM や PACL で登録しているフルパスのプログラムと一致しないため、定義されているルールとマッチしないことになります。

プログラムがフルパスで実行された場合は、一般的に /proc 配下のプロセス情報にはフルパスで記録されますが、フルパスで実行されなかった場合はプログラム名だけが記録されることになります。

PIM 起動後にプログラムを開始する際にフルパスで実行されなかった場合は、PIM のインターセプションデータとしてフルパスを認識しているため、フルパスの情報も含められてルールが正常に動作します。

本事象は現時点では仕様通りの動作となり、フルパスで実行されていないプロセスについては制限事項となります。

本事象は AIX、HP-UX では確認されていますが、Linux、Solaris では確認できておりません。

Resolution

本事象を回避するには以下のうちいずれかを実行してください。

  • 汎用ルールではなくプログラム名をフルパスで指定して登録してください。
  • プログラムの実行時に必ずフルパスで実行してください。
  • プログラムを PIM の再起動後に再起動してください。

Additional Information

なお、本KBは以下の英文 KB を翻訳し補足しました。

Article ID: 8187: Generic specialpgm or PACL doesn't work after restart