Accessing Clarity app post refresh of CERTS in LB results in ERROR AH01102
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Accessing Clarity app post refresh of CERTS in LB results in ERROR AH01102

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Article ID: 371338

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Updated On:

Products

Clarity PPM On Premise

Issue/Introduction

We have replaced the certificate in Apache Mod Proxy Load balancer and post which accessing the Clarity app is resulting in the below errors and we can't access application via LB

[Thu Jun 27 11:18:10.686852 2024] [proxy_balancer:error] [pid X:tid Y] [client *.*.*.*:PORT] AH01170: balancer://LBNAME: All workers are in error state, referer: https://CLARITY-HOSTNAME/niku/nu
[Thu Jun 27 11:19:52.336692 2024] [proxy_balancer:error] [pid X:tid Y] [client *.*.*.*:PORT] AH01170: balancer://LBNAME: All workers are in error state
[Thu Jun 27 21:14:35.255598 2024] [proxy_http:error] [pid X:tid Y] (20014)Internal error (specific information not available): [client *.*.*.*:PORT] AH01102: error reading status line from remote server SERVER_FQDN:SERVER_PORT, referer: https://CLARITY-HOSTNAME//niku/nu
[Thu Jun 27 21:14:35.255598 2024] [proxy:error] [pid X:tid Y] [client *.*.*.*:PORT] AH00898: Error reading from remote server returned by /niku/ui/uif/js/hook.js, referer: https://CLARITY-HOSTNAME//niku/nu

 

Environment

Component: CLARITY APPLICATION

Release: 16.x

Cause

The issue is occurring as the certificate change at the LB end is not recognized/trusted by Clarity application and hence request is rejected. It looks like an SSL Trust issue.

Resolution

  • Check the correct certificates are imported in LB and having a valid certificate chain