Unable to expand a VMFS datastore via the vSphere Client or the ESXi client
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Unable to expand a VMFS datastore via the vSphere Client or the ESXi client

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Article ID: 371313

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Updated On:

Products

VMware vSphere ESXi VMware vSphere ESXi 7.0 VMware vSphere ESXi 8.0

Issue/Introduction

 

After expanding the Lun backing the datastore, in the vCenter client, the Increase Datastore Capacity wizard does not present the storage device with available space:

Cause

This occurs if the datastore is force mounted.

A force mounted datastore cannot be increased in size.

Note: Force mounting also prevents a LUN being automatically mounted when presented to new hosts, and, in general, should be a temporary measure.

 

To identify a force mounted datastore please see:  Identify if a datastore is force mounted on an ESXi host

 

 

Resolution

To resolve this, the datastore needs to be re-signatured which will change the UUID of the datastore.

To re-signature a force mounted datastore, the datastore needs to be unmounted from all ESXi hosts. This will require migrating all VMs from the datastore or shutting down and unregistering them.

For detailed steps, impacts and best practices on how to resolve force mounted Luns, please see the following KB Troubleshooting LUNs detected as snapshot LUNs in vSphere

 

Additional Information

See the below KB for alternative reasons why you may be unable to expand a datastore via the vSphere Client:

Extending or increasing a datastore through vCenter Server fails