Unable to expand a VMFS datastore via the vSphere Client or the ESXi client
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Unable to expand a VMFS datastore via the vSphere Client or the ESXi client

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Article ID: 371313

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Updated On: 06-08-2025

Products

VMware vSphere ESXi VMware vSphere ESXi 7.0 VMware vSphere ESXi 8.0

Issue/Introduction

Symptoms:

  • After expanding the LUN backing a VMFS datastore, in the vCenter client, the Increase Datastore Capacity wizard does not present the storage device with available space:

Environment

VMware vSphere ESXi 7.0
VMware vSphere ESXi 8.0

Cause

  • This can occur if the LUN backing the datastore was detected as a snapshot and if the datastore was force mounted, without re-signaturing.

  • On a "force mounted" datastore the size cannot be increased  ( Datastore expansion )

  • Force mounting also prevents a LUN being automatically mounted when presented to new hosts.

  • Force mounting the datastore is just a temporary step to gain immediate access to it's contents.

  • From vmkernel logs of the host, the below entries can be seen which indicate that the LUN backing the datastore is a snapshot LUN:

    # Example 1:
    LVM: 8445: Device naa.####################:1 detected to be a snapshot:
    LVM: 8445: Device eui.####################:1 detected to be a snapshot:
    LVM: 8452: queried disk ID: <type 1, len 17, lun 36, devType 0, scsi 0, h(id) ##############76905>
    LVM: 8459: on-disk disk ID: <type 1, len 17, lun 17, devType 0, scsi 0, h(id) ##############76905>

    #Example 2:
    LVM: 11764: Device naa.####################:1 detected to be a snapshot:
    LVM: 11770:   queried disk ID: <type 2, len 22, lun 0, devType 0, scsi 0, h(id) ##############942001>
    LVM: 11777:   on-disk disk ID: <type 2, len 22, lun 0, devType 0, scsi 0, h(id) ##############986994>

  • To identify a force mounted datastore please see:  Identify if a datastore is force mounted on an ESXi host.

Resolution

To resolve this, the datastore needs to be re-signatured which will change the UUID of the datastore.

To re-signature a force mounted datastore, the datastore needs to be unmounted from all ESXi hosts. 

To unmount the Datastore, there should not be any active IOs, to ensure this:

  • Migrate all the VM(s) off the Datastore, or

  • Shut down all the VM(s) and unregister from ESXI ( make a note of VM and VMX files ) 

To re-signature a snapshot/replica LUN (the volume is mounted immediately after the re-signature with a new UUID,), run this command:

  • Please note the steps and warnings outlined in the Additional Information before executing this command.
    esxcli storage vmfs snapshot resignature -l label|-u uuid
  • For example:
    esxcli storage vmfs snapshot resignature -l "VMFS_1"
    esxcli storage vmfs snapshot resignature -u "########-########-####-############"

  • To (persistently force) mount a snapshot/replica LUN across reboots, run this command:
    esxcli storage vmfs snapshot mount -l label|-u uuid

  • To (non persistent force) mount a snapshot/replica LUN that is not persistent across reboots, run this command:
    esxcli storage vmfs snapshot mount -n -l label|-u uuid

For detailed steps, impacts and best practices on how to resolve force mounted LUNs, please see the following KB Troubleshooting LUNs detected as snapshot LUNs in vSphere.

Additional Information

When extension of a force mounted datastore is attempted from the vSphere Client, the partition table on the LUN may be extended (although the filesystem is not grown).

In that case, after the LUN is re-signatured, and the Increase Datastore Capacity wizard is run again, no available space is detected on the LUN. If this occurs, please engage Broadcom support to assist in completing extension of the datastore from the command-line

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See the below KB for alternative reasons why you may be unable to expand a datastore via the vSphere Client:

Extending or increasing a datastore through vCenter Server fails.