Cannot log in to the Admin console as Global Administrator and error "unable to update authentication token" in arcotadmin.log
search cancel

Cannot log in to the Admin console as Global Administrator and error "unable to update authentication token" in arcotadmin.log

book

Article ID: 371309

calendar_today

Updated On:

Products

CA Risk Authentication

Issue/Introduction

Global Admin authentication fails during login as Global Administrator even when Admin provides correct login credentials for Admin URL like - http://<Admin Console IP Address>: <Admin Console Port>/arcotadmin/adminlogin.htm fails with error below in the arcotadmin.log

Error while updating the authenticated user:  cause::Administrator 'ExampleAdmin" (Organization: EXAMPLEORG)'  does not exist; unable to update authentication token.

Environment

All supported AA versions.

Cause

Failure to update ARADMINAUTHTOKEN table post a successful authentication of the Global Admin. 

Resolution

ARADMINAUTHTOKEN table is missing key data for this Global  Administrator. Please examine and correct the ARADMINAUTHTOKEN table data. Ensure the Database User has permissions to update ARADMINAUTHTOKEN table. Then re-authenticate the Global Administrator.

Additional Information

None