Integration errors between SDM and PAM
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Integration errors between SDM and PAM

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Article ID: 371282

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager CA Process Automation Base

Issue/Introduction

While integrated with SDM and PAM, whenever SDM is accessing PAM related content, there is logging presenting as follows:

 

SDM stdlog:

07/01 20:10:31.64 SDM-SERVER pdm_proctor_nxd         4340 SIGNIFICANT  STDIO                    0 Jul 01, 2024 8:10:31 PM com.sun.xml.ws.mex.client.MetadataClient retrieveMetadata

07/01 20:10:31.64 SDM-SERVER pdm_proctor_nxd         4340 SIGNIFICANT  STDIO                    0 WARNING: MEX0008:Failed to parse metadata returned from server at http://PAM-SERVER:8080/itpam/soap using protocol SOAP_1_1. Continuing attempts.


PAM c2o.log

2024-07-01 20:10:31,606 ERROR [com.ca.pam.frontcontroller.C2OSoapControllerServlet] [ default task-1] C2OSoapControllerServlet: Invalid Request MethodGET

2024-07-01 20:10:31,622 ERROR [com.ca.pam.soap.ItpamSoapUtil] [ default task-1] Unable to build soap Envalop from request
com.sun.xml.messaging.saaj.SOAPExceptionImpl: Unable to internalize message
...
Caused by: com.sun.xml.messaging.saaj.soap.SOAPVersionMismatchException: Cannot create message: incorrect content-type for SOAP version. Got: application/soap+xml Expected: text/xml

 

Above log entries appear simultaneously in their respective logs and align with one another based on their timestamps.  Error can be induced by opening an SDM category or request area, and under the workflow, search through PAM tasks.  No errors present visibly on either PAM or SDM UI's and no apparent effects on integration are detected.  

Environment

Release 17.4 RU1 or earlier
CA Service Desk Manager

Release 4.4 CP02 or earlier
CA Process Automation Base

Above two products are running on separate servers each.

Cause

Issue is specific to older builds of SDM and Process Automation

Resolution

Issue no longer appears when SDM is updated to 17.4 RU2 and PAM is updated to 4.4 CP03

In some cases, we have seen that the above messages are generated when ITPAM flows incorrectly reference custom code in Service Catalog offerings.

Reminder that variables are case sensitive, so be sure the letters and capitalization matches.

Additional Information