unable to log in to OC after upgrading mysql database
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unable to log in to OC after upgrading mysql database

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Article ID: 371263

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

after upgrading mysql database, the user (both local admin and rdp user) is unable to log in to the operator console. 

After entering the credentials, OC reloads back to the login page without any error. 

The following error messages might be seen in the operator_console.log file : 

 

Line 8165: 2024-07-01 13:21:23.773 [http-nio-80-exec-1]  ERROR org.hibernate.engine.jdbc.spi.SqlExceptionHelper:logExceptions:142 spi.SqlExceptionHelper - (conn=106704) Table 'ca_uim.oc_session' doesn't exist
Line 8166: 2024-07-01 13:21:23.781 [http-nio-80-exec-6]  ERROR org.hibernate.engine.jdbc.spi.SqlExceptionHelper:logExceptions:142 spi.SqlExceptionHelper - (conn=106704) Table 'ca_uim.userhomepagepreferences' doesn't exist
Line 9320: 2024-07-01 13:56:22.609 [http-nio-80-exec-4]  ERROR org.hibernate.engine.jdbc.spi.SqlExceptionHelper:logExceptions:142 spi.SqlExceptionHelper - (conn=115155) Table 'ca_uim.uim_content_management' doesn't exist

Environment

UIM 23.4.x, 20.4.x 

Cause

Missing or corrupted tables in the UIM database, removed (or wrongly migrated / not recreated) as a result of MySQL database upgrade

Resolution

Take a backup or snapshot of the UIM and OC servers, and then reinstall UIM and OC servers - the installer should re-create the tables in the database. 

Reinstalling DX UIM Server

https://techdocs.broadcom.com/us/en/ca-enterprise-software/it-operations-management/unified-infrastructure-management/23-4/installing/reinstalling-ca-uim-server.html