Redeploying Aria Operations in SDDC Manager might fail due to admin account lockout
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Redeploying Aria Operations in SDDC Manager might fail due to admin account lockout

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Article ID: 371222

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Updated On:

Products

VMware Cloud Foundation VMware Cloud Foundation 5.x VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

While redeploying Aria Operations in LCM, it fails with the error code - LCMVROPSYSTEM25013

In vmware_vrlcm.log, we see below logs -

 com.vmware.vrealize.lcm.plugin.common.vrops.exceptions.InvalidCredentialException: Unauthorized access to VMware Aria Operations
 at com.vmware.vrealize.lcm.drivers.vrops.VropsEndpoint.getNodeState(VropsEndpoint.java:1950)
 at com.vmware.vrealize.lcm.drivers.vrops.VropsEndpoint.getMasterConfig(VropsEndpoint.java:192)
 at com.vmware.vrealize.lcm.plugin.core.vrops.tasks.BaseConfigureVropsTask.getMasterConfig(BaseConfigureVropsTask.java:172)
 at com.vmware.vrealize.lcm.plugin.core.vrops.tasks.BaseConfigureVropsTask.init(BaseConfigureVropsTask.java:86)
 at com.vmware.vrealize.lcm.plugin.core.vrops.tasks.RestartVropsClusterTask.initialize(RestartVropsClusterTask.java:135)
 at com.vmware.vrealize.lcm.plugin.core.vrops.tasks.RestartVropsClusterTask.execute(RestartVropsClusterTask.java:60)

Environment

VMware Cloud Foundation 5.x

VMware Aria Suite 8.x

Cause

This issue happens due to the presence of Aria Operations integration in Aria Operations for Logs which does not get removed automatically after removing previous vRops environment. Within this integration, the outdated credentials may be stored causing the admin account to lock on Aria Operations due to multiple failed login attempts from Aria Operations for logs. 

To identify and address the account lockout issue, please refer to the KB article here - https://knowledge.broadcom.com/external/article?legacyId=89599

Resolution

This issue will be addressed in a future release.

Currently, please follow the below steps to workaround this issue -

1. Delete the Aria Operations integration manually in Aria Operations for Logs

2. Reset the Aria Operations admin account password as per the KB article here - https://knowledge.broadcom.com/external/article?legacyId=2078313

3. Retry the deployment in Aria Suite Lifecycle