NSX-T IP Pool Deletion Fails with Realization Errors
search cancel

NSX-T IP Pool Deletion Fails with Realization Errors

book

Article ID: 371010

calendar_today

Updated On: 06-16-2025

Products

VMware NSX

Issue/Introduction

  • When removing Service VMs, Host Transport Nodes, or NSX Edges, the associated IP addresses sometimes remain assigned in the IP pool.
  • This issue can prevent the successful deletion of an IP Pool, causing ongoing management challenges.
  • The IP Pool was marked for deletion.
  • This can cause the realization of IP Pool deletion to fail with an error message similar to: "Received error cannot delete Partition 0 as it has allocated Ids deleting resource: <UUID> from NSX for <UUID>" in the IP Address Pools page."

Environment

VMware NSX-T 3.x and VMware NSX versions before 4.1.2

Cause

This issue is caused by a software defect in VMware NSX-T. 

 

Resolution

This issue is fixed in VMware NSX 4.1.2, please upgrade to this version to prevent the deletion of IP Pools before the allocation is released. 

Workaround: Releasing Stale IP Addresses:

  1. Check the IP Pool allocation before deleting. You can find the allocation information under Networking > IP Management > IP Address Pool.
  2. Look under the "Allocation" column of the IP Pool.
  3. If there are IPs still shown in the allocation, reconfigure the service/host/edges to not use an IP from this pool.
  4. If the object has already been deleted and the IP become stale, you can run the following API calls to get it released.
POST https://NSX-Manager-IP/api/v1/pools/ip-pools/<pool-UUID>?action=RELEASE

with the following inside the body of the POST request:

{

"allocation_id":"IP-Address",

"allocation_id":"IP-Address"

}

Please consult the NSX-T API guide for more information:
https://developer.broadcom.com/xapis/nsx-t-data-center-rest-api/4.1.1