NSX-T "Plan & Troubleshoot" tab shows "Something went wrong" or NSX UI shows distorted wording after deletion or removal of the NAPP feature
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NSX-T "Plan & Troubleshoot" tab shows "Something went wrong" or NSX UI shows distorted wording after deletion or removal of the NAPP feature

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Article ID: 371008

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Updated On:

Products

VMware NSX VMware vDefend Firewall with Advanced Threat Prevention

Issue/Introduction

In VMware NSX-T 3.x and NSX 4.x, when NAPP were removed either through the UI or force deletion using vCenter. 

  • There may have an error message "Something went wrong" under "Plan & Troubleshoot".
  • There may have extra wordings under
    • "System" tab such as "Navigation" right next to "NSX intelligence" (See below screenshots)
    •  "Plan & Troubleshoot" tab right next to "Discover & Take Action" (See below screenshots)
    • "Security" tab right next to "Malware Prevention" (See below screenshots)

 

When using API call: GET  /policy/api/v1/infra/domains/default/groups/sites/napp/registration

A similar result may display as the following:

{"module_name" : "common-services",     "error_message" : "The requested URI: /api/v1/infra/domains/default/groups/sites/napp/registration could not be found.",     "error_code" : 258 }

Environment

VMware NSX-T 3.2.x and VMware NSX 4.x

Cause

This issue is usually accompanied by force deletion of the NAPP VMs, or a failure of deletion of NAPP feature from NSX UI when the cleanup process is not triggered for the stale web elements on the NSX UI. 

Resolution

Please consult this KB article on how to remove the NAPP feature: https://knowledge.broadcom.com/external/article?articleNumber=368795

To resolve this issue, use a REST API client to run the two following API calls, exactly as shown below, against one of the NSX managers:

Please add "X-Allow-Overwrite: true" to the header of the DELETE request if it shows 4xx errors. 

Depending on where the distortion text is shown in the UI, run the following DELETE API calls matching the location.

  • Under "System" tab: 
    • DELETE https://nsx-manager-ip/policy/api/v1/ui-controller/remote-ui-plugins/platform-ui
    • DELETE https://nsx-manager-ip/policy/api/v1/ui-controller/remote-ui-plugins/upgrade-ui
  • Under "Security" tab: 
    • DELETE https://nsx-manager-ip/policy/api/v1/ui-controller/remote-ui-plugins/antimalware-ui
  • For all tabs: We need to reset the Intelligence plugin. 
    Please contact broadcom support to get assistance  in reseting the intelligence (pace-ui) plugin.