Edge Activation failing with unknown error occured.
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Edge Activation failing with unknown error occured.

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Article ID: 370900

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Updated On:

Products

VMware VeloCloud SD-WAN

Issue/Introduction

Edge activation failing with unknown error.

 

If this is related to hosted Orchestrator, engage SDWAN Support for further isolating the issue.

If this is related to on-prem infrastructure where Orchestrator is managed by customer/partner, Check if there any recent upgrade happened on the Orchestrator. 

This issue is mainly seen when Edge fails to get the certificate from Orchestrator

Check upload logs if you are seeing the below error.

xxxxxxxxxxxxx:/var/log/upload$ tail -f /var/log/backend/velocloud.log | grep -i 'CA private key'
2024-07-25T01:24:42.601Z - error: [generateCertificate.172184442.75403] [18928] failed to generate certificate -  failed to load the CA private key
2024-07-25T01:24:44.784Z - error: [generateCertificate.172184442.84582] [18909] failed to generate certificate -  failed to load the CA private key
2024-07-25T01:24:44.889Z - error: [generateCertificate.172184442.83787] [18829] failed to generate certificate -  failed to load the CA private key
2024-07-25T01:24:45.107Z - error: [generateCertificate.172184442.73866] [18942] failed to generate certificate -  failed to load the CA private key
2024-07-25T01:24:45.314Z - error: [generateCertificate.172184442.83356] [18826] failed to generate certificate -  failed to load the CA private key
2024-07-25T01:24:45.347Z - error: [generateCertificate.172184441.88819] [18713] failed to generate certificate -  failed to load the CA private key
2024-07-25T01:24:45.375Z - error: [generateCertificate.172184442.83357] [18826] failed to generate certificate -  failed to load the CA private key
2024-07-25T01:24:49.512Z - error: [generateCertificate.172184441.84481] [18727] failed to generate certificate -  failed to load the CA private key

Environment

All SD-WAN version

Cause

 CA passphrase was not set properly post upgrade.

 

Resolution

If "failed to generate certificate -  failed to load the CA private key"  error is seen on the Orchestrator backend logs then involve the SDWAN Support team to resolve the issue