Unable to open cdm probe in IM - Run-time error '-2147010985 (8000736b1)': Automation error
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Unable to open cdm probe in IM - Run-time error '-2147010985 (8000736b1)': Automation error

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Article ID: 370863

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) CA Unified Infrastructure Management On-Premise (Nimsoft / UIM) CA Unified Infrastructure Management SaaS (Nimsoft / UIM)

Issue/Introduction

I keep getting the following error when trying to open any cdm probe in the UIM environment.

conf_cdm

Run-time error '-2147010985 (8000736b1)':Automation error

Environment

  • DX UIM 20.4 CU7
  • cdm 7.20

Cause

  • Required dependency: vs2017_vcredist_x64
  • Opening IM (NimBUSManager.exe) from the command line instead of the Windows / Start menu selection

Resolution

Run-time error'-2147010895 (800736b1)':

Automation error
The application has failed to start because its side-by-side configuration is incorrect. Please see the application event log or use the command-line sxstrace.exe for more detail.


The error above is caused by missing dependencies for any given probe.

In the case of cdm, open the cdm package and the probe dependencies will be visible in the cdm package in the local archive:

The 'vs' package version required also depends on the probe version so it should be checked.

You can either download the required package(s) from http://support.nimsoft.com  and import them into your local archive then deploy them to the machine where you're running the Infrastructure Manager, or you can download them from Microsoft and install them.

microsoft.com/en-us/download/details.aspx?id=11895

The cdm requirements above are well documented and you can view the dependencies in the cdm package when you select the Dependencies Tab.

In this case, the original issue was resolved by deploying the vs2017_vcredist_x64 package to satisfy the dependency, but the cdm probe would still not open without error or it would open but display no data (empty).

As it turns out, the customer was running the IM, e.g., (<drive>:\Program Files (x86)\Nimsoft\bin\NimBUSManager.exe) from the Microsoft Windows command line (cmd) as the customers user account (not SYSTEM), and this was causing the last/issue.

Once I instructed the customer to open the IM via Start/Windows icon->Nimsoft Monitoring->Infrastructure Manager, the cdm GUI opened successfully and displayed cpu, memory and disk data instead of the GUI rendering with no data (empty).