Mail is not being processed by downstream MTA
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Mail is not being processed by downstream MTA

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Article ID: 370830

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Updated On:

Products

Data Loss Prevention Enterprise Suite

Issue/Introduction

Emails are queuing up upstream from DLP. 
Logs show that messages fail after 20 seconds. 

Environment

Request Processor logs show:
All forward hosts unavailable (tid= cid=<> reason=No available forward hosts)

Cause

20 seconds indicates we are likely encountering the timeout:
RequestProcessor.ForwardConnectionTimeout
If no MTA accepts our outbound connection in that time, we will return 'No available forward hosts'

Resolution

Verify that messages are being sent to the desired MTA with Wireshark or Use tcpdump to do a packet capture. 

If outbound connection attempts look correct, follow up with the owner/vendor of the upstream MTA.

If this issue occurred after a mail-flow change, it is likely that the IP used in the new configuration may not be accepted by the upstream MTA as a valid sender.