'Access is denied' error when opening an Adhoc View
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'Access is denied' error when opening an Adhoc View

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Article ID: 370814

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

The scenario under consideration is as below:

  • There are multiple Adhoc Views that throw the following error when they are accessed

    Access is denied (Error UID: 6c292922-0824-4f52-9043-71226d9809f2)

  • The Adhoc Reports that are connected to these Views open up without issues
  • When an export of these Adhoc Views is attempted a message is displayed that the View is being exported with missing dependencies

Cause

  • One or more components that the Adhoc View relies on, is no longer present. These would typically be components that were used during the Adhoc View's creation. They would not be components that are provided out of the box, with Jaspersoft.

Resolution

  • Avoid deleting files from Jaspersoft server, without making an evaluation of the components that might rely on them
  • Identify the columns that were part of the Adhoc View. Recreate it. It is recommended to keep a backup of all custom Adhoc Views, by exporting them along with their dependencies, in a content management system. These backups can be used to restore from.