Editing username in VMware Cloud Provider Lifecycle Manager fails with error "Datacenter fqdn or username cannot be updated"
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Article ID: 370715
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Updated On:
Products
VMware Cloud Director
Issue/Introduction
Unable to edit the username of vCenter instance in VMware Cloud Provider Lifecycle Manager fails with below Error :
Environment
VMware Cloud Provider Lifecycle Manager 1.6.X
Cause
Username of Data center components cannot be changed using the edit operation because component identifier is composed of FQDN and username.
Resolution
In order to update the name, perform below :
Export the component to JSON
Register it again (upload the JSON there) and use different username during that registration
Once the updated( new username) component is registered, delete the old one
Additional Information
If the vCenter is used, e.g. to deploy other products , in that case, it won't let you delete the old one. In that case, you would need to update the products that are deployed on that VC to point to the newly registered vCenter by performing below :
Select the product operations -> "Update environment Data"
This should be done with all products that use the old VC as deployment infrastructure. Once done, you should be able to delete the vCenter with the old username.