New UI VCO cannot display and configure the some applications in the per-profile settings
search cancel

New UI VCO cannot display and configure the some applications in the per-profile settings

book

Article ID: 370681

calendar_today

Updated On:

Products

VMware VeloCloud SD-WAN with Premier Support VMWare SD-WAN VMware SD-WAN by VeloCloud

Issue/Introduction

The new UI VCOs cannot display and configure some applications in the per-profile settings (Configuration->Profile->Business Policy). However, Old UI can display it.
For example, this issue happened when you or the administrator add a new application to the Application MAP.

Environment

Recent Case

In some case, New UI cannot display the below 4 Symantec applications in Business Policy Configuration 
-Symantec Cloud SWG Int. Services
-Symantec Cloud SWG Ext. Services
-Symantec Cloud SWG Portal
-Symantec WSS Agent (In the past, this application name was “Symantec Cloud SWG Tunnel Traffic”)

 

On the other hand, in Old UI,  We can display and configure the above 4 Symantec applications in Business Policy Configuration.

 

However, after configured in old UI, these apps show "invalid appid" in New UI.

Cause

The per-profile settings refer to the Application MAP in the customer's default operator profile. So we need to configure default operator profile which includes necessary application MAP.

Resolution

Workaround

  • Select operator profile which includes necessary application MAP in Global setting->Customer Configuration->SD-WAN
  • If "Allow Customer to manage software", select operator profile which includes necessary application MAP in Service Settings-> Edge Management->Software & Firmware Images

If the issue happens after setting the above, it's possible to be a browser cache problem.
Please clear the cache for the all period, close the browser, and try the settings again from the Profile side. If there is a large amount of cache, it may take several minutes for the deletion to complete.