NSX - stale NVDS switch after the NVDS to VDS migration is complete
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NSX - stale NVDS switch after the NVDS to VDS migration is complete

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Article ID: 370575

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Updated On:

Products

VMware NSX

Issue/Introduction

 

  • When checked in VC or the host CLI, the host still has the NVDS
    esxcfg-vswitch_-l

    DVS Name Num Ports Used Ports Configured Ports MTU Uplinks
    DVSwitch1 9216 6 512 1500 vmnic0,vmnic1

      DVPort ID In Use Client
      148 1 vmnic0
      149 1 vmnic1
      141 1 vmk0

    DVS Name Num Ports Used Ports Configured Ports MTU Uplinks
    DVSwitch2 9216 5 512 9000 vmnic5,vmnic4

      DVPort ID In Use Client
      8 1 vmnic4
      9 1 vmnic5

    Switch Name Num Ports Used Ports Uplinks
    NVDS-1 9216 6 vmnic2,vmnic3

 

  • Migration completion logs are seen under /var/log/proton/nsxapi.log of the NSX manager
    23:29:15.828Z INFO MigrateToCvdsTaskExecutor9 MigrateToCvdsTask 72011 FABRIC [nsx@6876 comp="nsx-manager" level="INFO" subcomp="manager"] MigrateToCvdsTask starting for Host <HOST-UUID>, isInternalCall true

    23:29:15.790Z INFO ActivityWorkerPool-1-16 MigrateToCvdsUtils 72011 FABRIC [nsx@6876 comp="nsx-manager" level="INFO" subcomp="manager"] NVDS-UPGRADE Successfully added host <HOST-UUID> to vds <VDS-ID>

    ......

    23:30:34.634Z INFO MigrateToCvdsTaskExecutor9 MigrateToCvdsTask 72011 FABRIC [nsx@6876 comp="nsx-manager" level="INFO" subcomp="manager"] Host <HOST-UUID> MigrateToCvdsTask Stage TN_MIGRATION_COMPLETED: TN NVDS to CVDS Migration completed, migrationTaskId = 155971703. migrationTaskPassed true
  • Since the problematic host is updated with the VDS switch information in NSX database, triggering another migration using API or CLI method might not work.

Environment

  • VMware NSX 4.x
  • VMware NSX-T Data Center 3.x

Cause

This stale NVDS is a result of an unsuccessful deletion from the host. 

Resolution

This is a condition that may occur in a VMware NSX environment.

If you believe you have encountered this issue, please open a support case with Broadcom Support and refer to this KB article.

For more information, see Creating and managing Broadcom support cases.