Telemetry Tile v2.1.4 Upgrade Bug: Usage Service Data Collection Issue and Resolution
search cancel

Telemetry Tile v2.1.4 Upgrade Bug: Usage Service Data Collection Issue and Resolution

book

Article ID: 370564

calendar_today

Updated On:

Products

VMware Tanzu Application Service

Issue/Introduction

In this article, we address a critical bug in the Telemetry for VMware Tanzu [VMs] v2.1.4 that affects the collection of Usage Service data. This bug impacts customers who have upgraded to version 2.1.4 and have opted into collecting Operational Data. 

Environment

  • VMware Tanzu Operations Manager
  • Telemetry for VMware Tanzu [VMs] v2.1.4
  • Tanzu Application Service (TAS) with Usage Service errand enabled

Cause

A bug in Telemetry for VMware Tanzu [VMs] v2.1.4 prevents the collection of Usage Service data for customers who have opted into collection Operational Data. This issue is specific to environments where the tile was upgraded to v2.1.4 from a previous version.

Resolution

There are two options to resolve the issue:

Direct upgrade option

  • Upgrade to Telemetry v2.1.6
  • Apply Changes

Delete and Redeploy with an older patch version

To use this option, customers must perform a full uninstall and reinstall the Telemetry Tile. Customers should ensure they install v2.1.5 upon reinstall.

  • Delete the Telemetry Tile from the Ops Manager UI
  • Redeploy
  • Install and configure Telemetry v2.1.5
  • Apply Changes