Changing password expiration in ESXi causes connections to disconnect in SDDC manager
search cancel

Changing password expiration in ESXi causes connections to disconnect in SDDC manager

book

Article ID: 370453

calendar_today

Updated On:

Products

VMware SDDC Manager

Issue/Introduction

Symptoms: 

  • Service account and root account passwords for ESXi show disconnected in the SDDC manager after changing the password expiration time in ESXi.
  • Wrong password noted for root and ESXi service account, which doesn't match the password saved in the SDDC database. 
  • ESXi passwords were changed outside the SDDC workflow
  • Unable to remediate ESXi svc-esxifqdn@domain service account password 

Environment

SDDC manager 4.x

SDDC manager 5.x

Cause

Changing the password expiration for the svc and root accounts in ESXi to a shorter date then when the password was last changed will cause the passwords to immediately expire and SDDC manager to show the passwords are disconnected

Resolution

Change the SVC account password in ESXi to a new password to clear the expiration and then remediate the password in SDDC manager.

Additional Information

If you want to keep the same service account password, you can pull the service account passwords with the following KB: Retrieve the service accounts credentials from SDDC Manager