UNable to use WCC agent inventory to upgrade some agents
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UNable to use WCC agent inventory to upgrade some agents

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Article ID: 370438

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Updated On:

Products

Autosys Workload Automation

Issue/Introduction

Some agents can be upgraded from the WCC Agent inventory screen and others can not.

Sample WORKING AGENT_INSTALL_DIR/spool/wcc_agent_cmd/*/cmd.log
20-06-2024 10:08:14      Staging in progress.
20-06-2024 10:08:14      http://<hostname>.<domainname>.com:8080/wcc/asi/rest/agents/1CED4B7E-CBDB-4E0C-A307-827B6BA3D74B/actionStatus
20-06-2024 10:08:14      respCode:200
20-06-2024 10:08:14      http://<hostname>.<domainname>.comt:8080/wcc/asi/rest/agents/1CED4B7E-CBDB-4E0C-A307-827B6BA3D74B/stageToAgent?platformwithArch=linux_amd64&version=12.1.01.00
20-06-2024 10:08:22      contentFile-setup_1CED4B7E-CBDB-4E0C-A307-827B6BA3D74B.zip
20-06-2024 10:08:31      UnZip
20-06-2024 10:08:33      Unzip Done
20-06-2024 10:08:33      12.1.01.00
20-06-2024 10:08:33      http://<hostname>.<domainname>.com:8080/wcc/asi/rest/agents/1CED4B7E-CBDB-4E0C-A307-827B6BA3D74B/actionStatus
20-06-2024 10:08:33      respCode:200


Sample FAILING AGENT_INSTALL_DIR/spool/wcc_agent_cmd/*/cmd.log
2d52e7ac42b4a21/cmd.log
20-06-2024 10:02:38      Staging in progress.
20-06-2024 10:02:38      http://<hostname>.<domainname>.com:8080/wcc/asi/rest/agents/D616037E-0C71-4540-89DE-AB6735E93E1D/actionStatus
20-06-2024 10:04:45      send status-FAIL Connection timed out (Connection timed out)
20-06-2024 10:04:45      http://<hostname>.<domainname>.com:8080/wcc/asi/rest/agents/D616037E-0C71-4540-89DE-AB6735E93E1D/stageToAgent?platformwithArch=linux_amd64&version=12.1.01.00
20-06-2024 10:06:52      Unable to invoke download url.Connection timed out (Connection timed out)
20-06-2024 10:06:52      http://<hostname>.<domainname>.com:8080/wcc/asi/rest/agents/D616037E-0C71-4540-89DE-AB6735E93E1D/actionStatus
20-06-2024 10:08:59      send status-FAIL Connection timed out (Connection timed out)

What needs to be done to correct this?

Environment

Autosys !2.x
WCC 12.x

Cause

Port 8080 is not open from Agent to WCC

Resolution

Open the firewall port 8080 from the agent to the WCC Server(s)

Additional Information