Error: During Installation Of NetOps Business Report Service {DB Connection Failed}
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Error: During Installation Of NetOps Business Report Service {DB Connection Failed}

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Article ID: 370257

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Updated On:

Products

DX NetOps CA Performance Management - Usage and Administration

Issue/Introduction

We are facing error "Database connection failed" during the fresh installation of NetOps Report Manager:

 

=============================================================================
Database Connection Test Failed
---------------------------------------------

Database connection test failed on: <HOSTNAME>:3306
Error Information :
Unable to open database connection :
( jdbc : mysql : // HOSTNAME: 3306/reporting?useUnicode=true&characterEncod
ing=UTF-8&useSSL=falsewith SRM_user) null message from server: " Host
'HOSTNAME_2' is not allowed to connect to this MySQL
server "

Please ensure that the supplied database hostname and port are correct
and that the database is running

->1 -  Re-enter Connection Information
   2 - Exit Installation

ENTER THE NUMBER OF THE DESIRED CHOICE, OR PRESS (ENTER) TO ACCEPT THE
DEFAULT

 

I am using the tech docs to configure pre-requisite for the service, I am installing NetOps Business Report Service on new instance like CABI.

Environment

Report Manager Service new installation

Cause

Hostnames provided without a domain information;
FQHN are required like : hostname.domain.com

Resolution

Use the FQHNs ,please:

CREATE USER 'SRM_user'@'FQHN' IDENTIFIED BY '<password>';
GRANT SELECT,EXECUTE ON reporting.* TO 'SRM_user'@'FQHN' ;
GRANT SELECT,EXECUTE ON srmdbapi.* TO 'SRM_user'@'FQHN' ;
FLUSH PRIVILEGES;

Additional Information