Error when running cafkey: "Could not open CAPKI shared library, errno is 126"
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Error when running cafkey: "Could not open CAPKI shared library, errno is 126"

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Article ID: 370251

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Updated On:

Products

CA Identity Manager

Issue/Introduction

Migrating IM to version 14.4, installed a new provisioning and connector server 14.4 on Windows Server 2019.
There is a need to change the CAFT encryption key, to set it at the same value as the existing CAFT agents running on Windows Standalone servers.

The following error is observed when attempting to execute the cafkey command:

C:\Program Files (x86)\CA\SharedComponents\CAM>set CAPKIHOME="C:\Program Files (x86)\CA\SharedComponents\ETPKI\CAPKI\CAPKI5"
C:\Program Files (x86)\CA\SharedComponents\CAM>caftkey -i c:\temp\caft.key Fg8,lUX
Could not open CAPKI shared library, errno is 126
caftkey: encryption not supported

Environment

Release : 14.x

Component : Identity Manager

Cause

The upgrade of PKI (used by several Broadcom products, including Identity Manager), results in files missing in a specific location - which are needed by caftkey.

Resolution

Copy the folder:
C:\Program Files (x86)\CA\SharedComponents\ETPKI\CAPKI\CAPKI5\Windows
and place it under the folder:
C:\Program Files (x86)\CA\SharedComponents\ETPKI\CAPKI

caftkey would now run as expected