Outbound mail for generated report is rejected with "554 Relay rejected for policy reasons"
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Outbound mail for generated report is rejected with "554 Relay rejected for policy reasons"

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Article ID: 370139

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

There might be 2 scenario's

1. Single node Aria Ops network test connection to SMTP will establish connection, but email trigger might fail with error "554 Relay rejected for policy reasons"  
2. In a scenario of two node cluster when the notification is triggered from one node it would go through while the node02 might fail.

    Snippets from the Analytics logs located at /storage/log/vcops/log

           

For report  WARN  [reportGenerationExecutor-1]  com.vmware.vcops.platform.notification.email.EmailConfig.fromTransmissionConfig - Unsupported service credential type for Email
WARN  [reportGenerationExecutor-1]  com.vmware.statsplatform.persistence.serviceCredential.ServiceCredentialDataService.getServiceCredential - ServiceCredentialSearchParam cannot be null ERROR [Sending Outbound Email message: 'Report_name'; To: ; [email protected]]  com.vmware.vcops.platform.notification.email.EmailSender.call - Failed to send email Outbound Email message: 'Report_name; To: ; [email protected]; 554 Mail from [email protected], rejected for policy reasons.For Report_name WARN  [reportGenerationExecutor-1]  com.vmware.statsplatform.persistence.serviceCredential.ServiceCredentialDataService.getServiceCredential - ServiceCredentialSearchParam cannot be null ERROR [Sending Outbound Email message: 'Report_name'; To: ; [email protected]]  
     
 

 

Environment

Aria operations 8.x

Cause

This generally happens if there is misconfiguration on the SMTP policy

Resolution

 

To resolve this issue, contact the email administrator to register all the nodes in the SMTP policy and make sure to have network communication to the SMTP server.