When querying the Spectrum SRM database directly, we noticed that not all alarms have a severity assigned.
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When querying the Spectrum SRM database directly, we noticed that not all alarms have a severity assigned.

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Article ID: 370138

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Updated On:

Products

DX NetOps

Issue/Introduction

We would like to use the SRM database to query data directly, but when notice that some Alarm ID´s do not contain a severity and the field is showing as 0.

Environment

Spectrum 22.x / 23.x

SRM Reporting Database

Cause

Not all events that are assigned to an alarm id have a severity.

Resolution

If you check the SRM field that is returned for orig_event_type you will see the event that created that alarm in decimal format.  For example if the orig_event_type is 67329 then converted to hex is 10701 which would be displayed as 0x10701 or 0x00010701 with the leading zeros.

If you check the Event Configuration Manager, you will see that there is no severity for this event and the response of 0 is correct.