Error: "No resource pools available in the selected vCenter Server" when trying to create a new Provider VDC
search cancel

Error: "No resource pools available in the selected vCenter Server" when trying to create a new Provider VDC

book

Article ID: 370135

calendar_today

Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • You added a new resource pool in the vCenter.
  • You are trying to add a new Provider VDC using the resource pool in the vCenter.
  • But when you move to the third page in the setup to a new provider VDC you hit the issue:

No resource pools available in the selected vCenter Server

Environment

  • VMware Cloud Director: 10.3.x and 10.4.x

Cause

The issue occurs when Cloud Director could not find the new resource pool in the vCenter. 

Resolution

To resolve the issue, Reconnect and Refresh the vCenter instance in the Cloud Director portal. 

  1. From the top navigation bar, under Resources, click Infrastructure Resources.
  2. In the left panel, select vCenter Server Instances.
  3. Click the radio button next to the name of the target vCenter Server instance and click Reconnect.
  4. To confirm, click OK.
  5. Click back at the radio button next to the name of the target vCenter Server instance again and click Refresh.

Additional Information

For more information, see Reconnect a vCenter Server Instance.