Internal Server Error in Identity Portal when approver click on file in the form
search cancel

Internal Server Error in Identity Portal when approver click on file in the form

book

Article ID: 370037

calendar_today

Updated On:

Products

CA Identity Suite CA Identity Portal CA Identity Manager

Issue/Introduction

In Identity Portal cluster environment when approver wants to see the file attached to the form they see Internal Server Error.
When logs are checked error like this is found:
 
ERROR [com.idmlogic.sigma.workers.utils.ExceptionsHelper] (default task-533) : java.io.FileNotFoundException:
 

Environment

Environment with more than 1 server (or cluster) of Identity Portal 14.X

Cause

Files attached to the forms are stored only on machine which handled the form submission.

Resolution

Mounting Network Drives should be used for File Upload root location if Identity Portal cluster is in use.
This ensures both machines have access to same files uploaded by users.
 
 

Additional Information

If for some reason proposed solution is not possible rsync can be used but it will be slower as it will be scheduled per cron.